最新消息:

centos 中php的升级的血泪

PHP yuhouluomo 126浏览 0评论

情景:centos6.8 中安装通过更改yum源的方式安装了php5.6.30并采用了默认安装,没有安装gd库,导致图片生成不了。本以为直接一个 yum install php-gd 完成的事,竟然费了一下午。

尝试1: yum install php-gd 版本不一致

我的服务器自带的php版本为5.3.x ,没办法直接安装。

尝试2: 直接下载php5.6.30源码 只编译安装gd库

这个方法百度时看到好多次都没有尝试成功

尝试3 直接卸载原来的 php 重新安装

重新安装需要先卸载原来的版本

卸载方式1.yum remove php-*

卸载方法2. rpm -qa |grep php 查看php相关的包

rpm -e –nodeps +包名 然后逐个卸载

–nodeps 加这个参数是为了不查看依赖关系直接卸载,请慎用

然后 然后使用 yum 重新安装

yum install –enablerepo=remi –enablerepo=remi-php56 php

后面一定要记得加上需要用到的扩展包

如果你有好的解决办法欢迎提供,谢谢

转载请注明:PHP学习 » centos 中php的升级的血泪

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址